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TUTORIAL INTRODUCTIONS TO CAD

DRAWING WITH AUTOCAD 2000 - INTRODUCTION

Jim Plume

This is the first of a series of tutorial introductions to CAD.  The overriding aim
with these tutorial guides is to give you a firm conceptual understanding of CAD,
the scope of techniques available for design and presentation, and strategies for
approaching a variety of CAD tasks.

In this first tutorial, we will go through the process of starting up AutoCAD on the
computer and then look at some of the basic drawing and editing commands.  In
the next tutorial, we will begin the process of drawing something very simple in
order to learn how to attack a drawing task with this system.  These tutorials are
deliberately verbose, explaining concepts and ideas as you along.  It is
important, therefore, that you take the time to read and understand those
explanations.

These tutorials are written for AutoCAD 2000 running under the Windows 95/98
operating environment.  Some of the later tutorials make use of enhancement
packages that are sold in conjunction with AutoCAD to address specific
disciplinary CAD modelling tasks.

GETTING STARTED
It is assumed here that the reader is familiar with the general operation of
Windows 95/98.  If not, then there is a separate handout that explains the
Windows operating environment, how to manipulate files and windows, how to
execute application programs and how to use the Help facility in Windows.

With the release of AutoCAD 2000, AutoDesk has altered its marketing strategy
by packaging its base product with various enhancement packages related to
specific disciplines (as well as selling the base product separately).  Within our
Faculty, we use two of those packaged products:  Architectural Desktop (for
building design) and Land Development Desktop (for landscape design
applications).  Other packages include Mechanical Desktop (for product design)
and Civil Desktop (for advanced land engineering).

This tutorial can be run on any of those desktop packages, but it concentrates
on the general characteristics of AutoCAD 2000.  Later tutorials deal with the
specific tools available in those other packages.  All the screen shots included in
this tutorial came from the Architectural Desktop package.

To run AutoCAD 2000, simply select Start > CAD Applications > Architectural
Desktop 2.0 from the Windows Start Menu.  In the Startup dialogue box, pass
your mouse pointer over the four options available:  open an existing drawing;
start a new drawing with minimal preset values;  start a new drawing based on a
template file which effectively pre-selects a large number of options including
title blocks, text styles and things like that;  or you can use a wizard that walks
you through the process of selecting drawing units and paper size.  For this
tutorial, start a new drawing from scratch using metric units.

C1

Architectural Desktop 2.0
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LAYOUT OF THE AUTOCAD SCREEN
This installation of AutoCAD is almost exactly as it is shipped from the
distributor:  there are virtually no local adjustments.  The layout of the screen is
depicted in Figure 1.  The key components of the screen are:

Figure 1  Layout of the AutoCAD Application Window

•  Drawing Window:  covering most of the screen and contains the drawing
cursor that is used for pointing, and moves as the mouse is moved about.
The axis icon in the lower left corner shows the X and Y axis directions.

•  Pull-Down Menus:  across the top of the screen operate in the same way as
all Windows menus.  Note that the Concept, Design and Documentation
menus are part of Architectural Desktop and should be ignored for the
purpose of this tutorial.

•  Docked Toolbars:  in the initial setup, these are arranged across the top of
the screen below the pull-down menus and down the left side of the drawing
area.  These consist of sets of button tools, each performing some function
(to be explained later).  As you pas the mouse pointer over a button it
becomes highlighted, and if you pause for a moment, a tool tip appears to
identify the button.

•  Floating Toolbars:  as well as docking a toolbar along one of the edges of
the drawing area, you can have any toolbar “floating” anywhere on the
screen.  In the initial setup, there are no floating toolbars on the screen.

If you position the mouse pointer at
the top or bottom of any of the
docked toolbars, hold down the
mouse button and drag it onto the
drawing area, then that toolbar will
switch to a floating one.

Pull-down Menus

Crosshair Cursor

Standard ToolbarObject Properties Toolbar

Draw Toolbar

Modify Toolbar

Coordinate System Icon

Model and Layout Tabs

Command Window with Command Line below

Status Line with Toggle Buttons
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•  Command Window:  immediately below the drawing area is a command
input area with the standard AutoCAD command prompt (“Command:”) on
the left.  If you type anything on the keyboard, then it will appear on that line.

•  Status Line:  across the very bottom of the screen.  This displays status
information (such as the current coordinate location of the cursor in the
drawing area).  The labelled boxes at about the middle of the status line are
“toggle settings” that can be turned on or off by clicking with the mouse ... we
will come to these in due course.

Before proceeding, experiment with these various parts of the screen (if you
inadvertently execute a command, it doesn’t matter because you can cancel it
by pressing the <Esc> key on the top left of the keyboard!!).  Move the drawing
cursor around the drawing area and note how the coordinate position is updated
on the status line.  Explore the pull-down menus by clicking them with the
mouse.  Try typing something at the Command prompt to see what happens,
and try toggling one of the settings on the status line.

Next, try re-positioning the toolbars using each of the techniques as follows:

•  if you move the mouse pointer to the top of any docked or floating toolbar
and then hold down the left mouse button, you can drag it to any position on
the screen;

•  as soon as you drag a toolbar to the edge of the screen, it changes shape
and, if dropped, will attach itself as a docked toolbar to that edge;

•  if you drop it anywhere away from the edge, then it becomes a floating
toolbar;

•  if you position the mouse pointer on the edge of any floating toolbar (so that it
changes to double-headed arrow), then you can hold down the left mouse
button and “drag” the toolbar to a different shape;

•  to bring up other toolbars that are not already on the display, pull down the
View menu and select Toolbars ... you will get the dialogue box illustrated on
the left ... click the check box next to the Toolbar that you would like to open.
The buttons in this dialogue also allow you to customise the toolbars, but you
are left to experiment with that yourself.

•  if you position the mouse pointer over any toolbar button and pause for a
second or two, then a pop-up box identifies that button!

Before proceeding, it may be helpful to put everything back roughly where it
appears in Figure 1!!

THE AUTOCAD COMMAND SYSTEM
The first thing to understand about AutoCAD is how the command system
operates.

Everything in AutoCAD is achieved by issuing a command.  Generally,
commands are entered by clicking a toolbar button or selecting the command
from a pull-down menu.  In rare cases, a command has to be typed in at the
Command prompt (where there is no equivalent toolbar or menu option).  In
some cases, a particular command can be entered in any one of those three
ways depending on your personal preference.  To complicate the matter further,
some commands can be typed in with an abbreviated alias, which is often the
quickest way to get the command started.

Once a command has been issued, AutoCAD displays a prompt (or instruction)
on the command line indicating your options for proceeding with that command.

Exploring the AutoCAD Window
Layout ....

Moving and Re-Sizing Toolbars

Toolbars dialogue box

Issuing AutoCAD commands ...

AutoCAD Prompts ...
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You should get into the habit of watching those prompts very carefully so
that you know where you are at any time.

To see how the command process operates, watch the command line as you
click on any toolbar button.  You will see the corresponding command printed at
the command prompt and then, as AutoCAD responds to the command, it will
display some kind of instruction or prompt (on the same line) and then wait for
you to respond.  Remember to press the <Esc> key if you wish to cancel the
command (unless you want to carry it through to see what happens).

The Command Line Prompt always follows the same “pattern”.  AutoCAD first
tells you what it expects you to do (“enter a point”, “type in a value”, etc).  If there
are other alternative actions you can take as part of that command sequence,
then those are listed next within square brackets, each separated by a slash
character.  You can select any of those alternative options by typing the
capitalised letters only of the option.  At the end of the prompt line, if
appropriate, AutoCAD displays the default answer to the prompt within angle
brackets.  If you simply press the Enter key, AutoCAD will use that default value.

To develop your understanding of this process further, choose any of the
drawing tools, click the button while watching the command prompt, and then
pick points in the drawing area in response to the prompts.  You should be able
to draw things with very little further explanation!

WORKING WITH THESE TUTORIALS
The purpose of this first tutorial is to enable you to become familiar with
AutoCAD so that you can begin your first drawing.  Please note a couple of
pieces of advice regarding the use of these tutorials:

•  when following the instructions in this tutorial, be certain to observe the
prompts on the command line ... this will help you develop a better
understanding of the logic that underlies this system;

•  these tutorials deliberately inter-mix explanations, instructions and comments
so that you don’t slip into a pattern of simply following instructions like a robot
- it is important that you patiently read everything as you work through the
material, endeavouring to understand each step of the process - don't treat
the tutorials simply as “recipes for drawing”!

The following table shows the conventions that are used in these notes to aid
you in following the steps necessary to use AutoCAD.  It is important that you
understand these so that you know how to interact with AutoCAD.

 [Draw.Line] When I want you to select a tool from a toolbar, I will
enclose its name in square brackets.  The Toolbar name is
given first, followed by the Tool name (separated by a full-
stop).  Where it seems appropriate, a graphic in the left
margin will be used to help identify the Tool button.

Note:  The process of finding the correct Tool button is
complicated by the fact that some Tools (particularly on the
Standard Toolbar) are grouped into sets of related Tools
known as Flyouts and are only visible if the Flyout is
displayed.  An arrow in the lower-right corner of the button
(as in the example on the left) identifies a Tool that has a
Flyout attached to it.  Display the Flyout by holding the left
mouse button down while pointing to the Tool button.

File > New This form is used to identify things that are to be picked
from the pull-down menus.  The “>“ symbol means “and
then pick”, so the example could be read “pick the File (pull-

The quickest way to learn is to
have a go, and try to make sense
of it yourself!!

A note about interpreting
AutoCAD’s command prompts …

The left margin in this tutorial will
be used to add commentary to the
text, identify the key topics being
discussed in particular paragraphs
(to enable scan reading and
facilitate finding things later) and to
include small illustrations where
appropriate.

Line Tool in the Draw Toolbar

An example of a Tool Button that
has a Flyout Toolbar associated
with it …
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down menu) and then pick the New option”.  Note that the
underlined characters show the keyboard short-cut for that
menu selection, in this case <Alt-F-N> (hold down the Alt
key while pressing F and then N).

circle ↵↵↵↵ Bolded type is used to indicate entries that are to be typed
on the keyboard in response to an AutoCAD prompt.  These
may be one character or several characters.  The symbol
“↵ “ represents either the <Enter> key or the <Space Bar>,
since both are considered equivalent in AutoCAD and
perform exactly the same function (that is, they indicate the
completion of a user action).

<F2> Bolded items in angle brackets represent keyboard keys
that are to be pressed once in order to invoke a particular
function in AutoCAD - in this example you would press the
keyboard key labelled “F2”.

PREPARING TO DRAW WITH AUTOCAD
When working with CAD we always operate with the real-world sizes of the
objects we are designing.  In Australian building practice, we use millimetres as
our basic unit of measure to describe architectural dimensions.  That means that
we typically deal with large whole numbers with no decimal places.  For this
tutorial, we will define a drawing size to suit a “model world” which is 20,000 x
15,000 millimetres, being large enough to model a fairly modest-size building.
The choice of model world size is entirely arbitrary:  its purpose, as you will see,
is merely to define an area within which to work.

To set up these parameters, proceed as described below.  Note that the steps
that you should take are given on the left (following the notations given in the
previous section), with brief explanations where appropriate on the right.

Format > Units calls up the Units Control dialogue box (illustrated) - select
Decimal units with 0 precision and Decimal Degrees with
0.0 precision and then click OK.

Format >
Drawing
Limits

executes the Limits command - this is the command that
defines the drawing size, in this case, in model space -
notice that AutoCAD prompts you, on the Command line, to
specify the lower-left corner of drawing limits.

↵↵↵↵ to accept the suggested value of (0,0) as the coordinates
of the lower-left corner of the drawing area - note that
AutoCAD always displays suggested values in angle
brackets.

20000,15000 ↵↵↵↵ to specify the upper-right corner coordinates - this
represents the largest drawing area that we expect to need
for this drawing - we can always change it later if
necessary.

Having set the drawing limits, we now need to instruct AutoCAD to display the
whole of that area on the screen.  At the present moment, it is only displaying a
small portion of the drawing area (about 420 x 297 units out of 20000 x 15000!)
because that is the default metric drawing size when AutoCAD is shipped.  You
ought to check that by moving the mouse pointer around the drawing area,
noting the coordinate position displayed in the status area.  To display the whole
sheet, proceed as follows:

AutoCAD allows us to model
design objects in their real-world
size in XYZ coordinate space.  This
is referred to as Model Space.  We
can also work in one or more layout
spaces where we arrange scaled
views of the design object on a
model of a sheet of fixed size
paper.  This is often referred to as
Paper Space.  In both cases, we
are working with scaled views on
the screen, in one case of the
design object itself, in the other, of
the paper-based drawing we
eventually plan to plot.

This paragraph highlights
AutoCAD’s flexibility in working with
different drawing units.
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[Standard.
Zoom All]

issue the command Zoom with the option All - check out
the Command Window to see the way AutoCAD prompts
you as you enter this command and then enters the
response by itself!!  Button Tools can be programmed to
execute several commands, including all the necessary
responses in order to perform quite complex operations.

DRAWING WITH AUTOCAD
All drawing operations performed with AutoCAD are initiated by issuing
commands through the Toolbars.  The first aim of this tutorial is to make you
familiar with the process of drawing by introducing the basic drawing and editing
commands.

Creating New Graphics Entities
Most of the commands to create new graphic entities are in the Draw Toolbar.
Similarly, the commands to manipulate and change those graphic entities are in
the Modify Toolbar.

Helpful Hint:  One last little reminder that you will find most useful!  Very
often with AutoCAD, you will begin to execute a command and then decide
that you need to cancel that operation.  To cancel any command and get
back to the "Command:" prompt, simply press the <Esc> key on the top-left
of the keyboard.

The following sections describe generally how to use each of the principal
drawing commands.  You should work through each of these, trying to
understand the process more than the specific detail of each command.

[Draw.Line] issue the Line command using the Draw Toolbar.

Note the prompt that appears on the command line.  Now if you click any point
on the drawing, then the beginning of the line is fixed at that point ... after that,
as you move the mouse around the line stretches with the crosshair cursor ...
this is referred to as rubber-banding.  Construct a few lines anywhere you wish,
then press <Enter> to terminate the command.

AutoCAD has two other types of line that are used when setting up drawings:
Construction Lines start at a notional “midpoint” and extend infinitely in both
directions (available on the Draw Toolbar);  while Rays have a fixed start
position and extend infinitely in only one direction (this command is available
through the pull-down menu … Draw > Ray).  Both these are designed to assist
drawing construction, and would not normally be plotted as part of the finished
drawing (though they can be!).  Experiment with both these types of lines.  We
will be able to make use of these when we get on to a serious drawing task in a
later tutorial!

[Draw.Circle] Issue the Circle command and construct a few circles
experimenting with the options on the command line … the
options are separated by a slash (/) character … you can
choose an option by typing the capitalised letters at the
start of each option ...

Notice that there are several ways of constructing circles:  by specifying the
centre point and radius;  by specifying the endpoints of a diameter;  by picking

Zoom All Tool button

Remember that all these
commands can be executed by
typing the command at the
Command: prompt, however, we
will generally use the mouse to
choose the command that we wish
to use from the Toolbar or the pull-
down menus.

The Line Tool

Rays & Construction Lines

Construction Line tool

Circle Tool …
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any three points on the circumference;  etc.  If you select the Draw > Circle
command from the pull-down menus, then AutoCAD will automatically pre-select
options before you begin the command.  Try that out to see how many different
ways you can construct a circle.

There are several other tools for drawing primitive geometric entities, including
rectangles, arcs, ellipses and regular polygons.  You should experiment with
each one by watching the prompts and trying to discern the range of options that
are available for the construction of each one.  By the time you’ve done that, you
will have a nice cluttered drawing!

Useful shortcut to remember:  whenever the “Command:” prompt is on the
Command Line, then you can recall the last command simply by pressing
the <Enter> key (or the <Space Bar> or the right mouse button) ... this
feature is very useful when you are doing the same operation over and over
again ... try it with some of the drawing commands.

The last graphic primitive that I want to introduce in this tutorial is text.  AutoCAD
provides a very powerful set of tools to produce text on drawings.  The first step
always is to create a text style to be used.  A style is defined by a font (which
can be either a special AutoCAD font or any Windows font loaded on the
computer you are using), combined with other properties like mirroring or turning
the text upside down, etc.  You can create quite dramatic effects with AutoCAD
text.

Select Format > Text Style from the pull-down menus to open the dialogue
shown below.

Once you have created a style, click Apply to make it the “current style” and then
close the dialogue box.  I want to introduce two basic commands that are used
to create new text entities.

Draw > Text >
Single Line
Text

this command is only available through the pull-down
menus, and allows you to enter one or more single lines of
text ... each line is treated as a separate entity ... notice on
the Command Line that you are prompted to enter a start
point ... pick a point somewhere in the drawing area (to

Rectangle tool

Arc tool

Ellipse tool

Regular Polygon tool

AutoCAD Text facilities …

Text Style Dialogue box …

Click the New button to create a
new style.  I called mine
“HandLettering” and chose a
Windows font that has a hand
lettering style to it.  You can try
setting some of the other effects if
you wish.  Note that by setting the
height to 0 (zero), the actual height
of the text can be set when the text
is created.

Single Line Text …
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mark the desired bottom left corner of the first character in
the text string) ... you will then be asked for the text height
...

500 ↵↵↵↵ this specifies the text height (note that at a plot scale of
1:100, this text would be 5 mm high).

↵↵↵↵ by simply pressing <Enter>, you are accepting the offered
value of 0 for the text angle ... AutoCAD generally offers
“default” values for most requested input ... the default
value is shown in angle brackets on the Command Line.

The Command Line prompt should now read “Enter Text:”, indicating that you
should enter the text that you wish to appear on your drawing.  A text box will
also appear at your specified starting point.  You can enter as many lines of text
as you wish, each terminated with <Enter>.  To stop the process, simply press
<Enter> twice (the second time, at the Enter Text: prompt, effectively terminates
the command).

Try using the Single Line Text command again (just by pressing ↵↵↵↵  to recall the
command), but this time, instead of typing the text height as a number, use the
mouse pointer to pick two points on the screen that "shows" the text height that
you want.  In general, AutoCAD will always allow you to “point” to a distance (by
picking two points) just as it also lets you type in a coordinate pair (x and y
values) instead of picking a point on the screen.

[Draw.Text] this command allows you to enter several lines of text
inside a dialogue box ... AutoCAD will prompt you (on the
Command Line) to pick two points that form the opposite
corners of a rectangle that defines the area in which the
text is to be positioned ... the Edit MText dialogue will then
appear.

Enter a few lines of text in the dialogue box and then click OK.  Notice that the
text wraps automatically in the dialogue box to fit within the width of the
rectangle that you defined.  You may notice also that if there is too much text to
fit in the rectangle, then AutoCAD simply allows it to spill over the lower
boundary of your rectangle.  Once the text is on the drawing, it is treated as a
single entity by AutoCAD.

Manipulating the View in the Drawing Area
Before looking at a couple of the AutoCAD editing commands, we will take a
moment to learn about some of the techniques available to control the displayed
view of your drawing within the drawing area.

The first of these is the Zoom command.  This allows you to change the scale of
the view on the screen so that you can focus in on smaller details or expand out
to see a larger area of the drawing.  Try the following variations on the Zoom
command:

[Standard.
Zoom
Window]

click this button and then point to two locations on your
drawing that mark opposite corners of a rectangle ...
everything within that rectangle will then be re-drawn to fill
the whole drawing area … notice that if you hold down the
left mouse button over this tool, then you get the Zoom
Flyout … while holding the left button down, pause over
each button in the flyout and read what it does … the
second-last one in the flyout is the most useful of these:  it
zooms out so that you can see everything in your drawing.

There is an important lesson in this
paragraph ...

Text tool on the Draw Toolbar

Introducing the Zoom Command

Zoom Window tool
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[Standard.
Real Time
Zoom]

This tool allows you to dynamically change the size of the
drawing on the screen … click the button once and then
move the mouse into the centre of the drawing area …
now, while holding down the left button, move the mouse
up and down the screen and observe the effect … press
<Esc> to cancel real time zoom.

[Standard.
Zoom
Previous]

this tool returns you to the previous view of the drawing ...
you can use it repeatedly to switch through up to 10
previous views.

The second way of changing the view is to use the Pan command.  This allows
you slide your view across the drawing while keeping the display scale constant.
Once understood, it is a very useful command ... try experimenting with it as
follows:

[Standard.
Real Time
Pan]

this tool is used to move across your drawing ... click the
tool once and then move the mouse pointer into the
drawing area … again, hold down the left button and drag
the drawing across the drawing area … press <Esc> to
cancel real time pan.

Note:  When using either of the Real Time Zoom or Pan tools, you can click the
right mouse button to pop up a menu that allows you to switch between the tools
or to exit from whichever one is active at the time.

The third way to move around a drawing, of course, is to use the Scroll Bars on
the right and bottom edge of the Drawing Window.  These operate like any
Windows application.

Modifying and Changing Graphic Entities
The simplest and most intuitive way to edit entities in a drawing is to make use
of entity handles.  If you position the crosshair cursor so that the small square at
the intersection of the crosshairs is over one of the entities in your drawing, and
then click the left mouse button, that entity will become highlighted with small
box “handles” positioned at its key points.  This is illustrated in the margin for a
number of different entity types.  Once selected in that fashion, you can use the
mouse to “pick up” one of the handles (by positioning the mouse over the handle
and holding down the left mouse button), and then drag that handle to a new
location in order to reshape the entity.  You can also pick up a selected entity
and drag it to a new location by picking up the appropriate handle.  The best way
to understand these techniques is to experiment with your drawing until you feel
that you have begun to master the technique.  You should also look up the Help
facility to gain further insights into how to manipulate entity handles.

A more controlled approach to editing is to use one of the editing tools
supported by AutoCAD:  we will look at erase, move and copy.  In each case,
you need to select the entities upon which you want the editing command to
operate.  If you have already selected one or more entities (in the manner
described in the previous paragraph), then those entities are assumed to be the
ones upon which the command is to operate.  If there are no entities “currently
selected”, then the command will prompt you to select some objects before it
proceeds with the editing process.  To understand these processes, work
through the following steps making random selections of objects where
required:

Real-Time Zoom Tool

Zoom Previous Tool

The Pan command ...

Real Time Pan tool

Scroll Bars ...

Editing with Entity Handles ...

The Editing Commands ...
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<Esc> <Esc> pressing the cancel key twice will ensure that any entities
that are currently selected in your drawing (with entity
handles visible) will be de-selected ...

[Modify.Erase] once this command has been issued, note that AutoCAD
prompts you to on the Command Line to “Select Objects:”
... pick a few objects to delete and then press ↵↵↵↵  to
complete the command ... the selected objects will
disappear!.

[Modify.Copy] again, when prompted, pick a few objects to copy and then
press ↵↵↵↵  ... this time AutoCAD prompts for a “Base Point:”
followed by an “End Point:” ... pick any two points on your
drawing that indicate a displacement vector ... the selected
objects will be moved over a distance and direction that
matches the displacement vector defined by your two
picks.

After the Copy Command has completed, try pre-selecting a couple of entities
before issuing the Move command as follows:

[Modify.Move] this command operates exactly like the Copy command,
except that the selected objects are moved rather than
duplicated ... notice that there is no prompt to select the
objects because they were pre-selected in this case!

You should now spend some time experimenting with these and the other
Modify tools, including:  scale, mirror and rotate.  The other modify tools
probably need further explanation, but you can try them if you wish!

One last comment on editing!  If you select any object in your drawing and then
click the Right Mouse Button, you will get a pop-up menu giving you several
options for manipulating that object.  Many of those options will be specific to
type of entity that you have selected.  For example, the two types of text entity
will each have an option to allow you to edit the text in that entity.  You are also
able to bring up a properties box in which you can edit many of the specific
properties of that entity.  You should experiment with that technique as it will be
useful in all sorts of circumstances!!

When you have finished experimenting, simply pick File > Exit in order to finish
this Session.  Because you have worked on a drawing without storing that
information on a file on the system, AutoCAD will ask if you wish to save the
changes.  In this case, simply click “No” (because there is no need to "save" the
work that you have done in this tutorial).  Normally, of course, you would want to
save the changes that you have made:  the Save and Save As options in the
File menu support those operations.

Erase tool

Copy tool

Move tool

Rotate, Scale & Mirror tools.

Using the Right Mouse Button …

Finishing the Tutorial ...
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